Troubleshoot OCF Connectors

Alation Cloud Service Applies to Alation Cloud Service instances of Alation

Customer Managed Applies to customer-managed instances of Alation

This topic contains information to help you in troubleshooting common issues.

OCF Logs

This section explains the steps to collect logs if you encounter errors while using an Open Connector Framework (OCF) connector. These logs capture the connector’s operations, data source interactions, and any errors or issues. Alation Support will analyse the logs to find the cause of the errors and help rectify them. The log collection steps differ based on the Alation deployment type: customer-managed or Alation Cloud Service.

Find more details in:

Unknown Connector State in Manage Connections

Problem

After upgrading Alation, a connector’s status appears as Unknown in the Manage Connections section.

Symptoms

Reviewing the Alation Connector Manager’s container logs reveals a 500 Internal Server Error, as shown below, accompanied by a failure to redeploy the container:

{"level":"error","msg":"failed to redeploy connectors ID 2 during initialization: Error response from daemon: No such container: <long-form container UUID>","time":"2023-02-21T20:43:54Z"}

Cause

During an Alation upgrade, you may be required to upgrade the Alation Connection Manager. During the upgrade process, the agent service Docker container is replaced, and containers associated with the Open Connector Framework (OCF) may be restarted or redeployed. If the new agent container fails to synchronize the connector information or the container image gets corrupted, the connectors may fail to restart or redeploy successfully. This can result in an Unknown status for the installed connectors.

Solution

Solution involves a process of restorin OCF connectors from a backup and redeploying. For more information refer to Troubleshooting.

Note

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